Subs

Please make a educated guess to the level of difficulty in the question you are asking.
sv3800
Posts: 3
Joined: Sun Jul 23, 2006 11:34 am
Location: Tasmania, Australia
Contact:

Subs

Postby sv3800 » Mon Sep 18, 2006 12:31 pm

At the moment I am running a rockford fosgate P110S4 (150WRMS) Sub off a Sony (350W max) amp.
I can smell a burning smell sometimes, am I overpoweing the sub??
As this is the second sub I have had warrenty will not cover this one if the same thing happens again.
scar-non

InstallGarage
Posts: 75
Joined: Mon May 22, 2006 6:38 pm
Location: North East USA

Postby InstallGarage » Mon Sep 18, 2006 8:47 pm

Without knowing the exact specifications on the amplifier, I would say you are fine to a certain degree. If you are going around blasting it at full volume and eq on bass for hours on end it is overpowered. You are probably pushing the subwoofer to the limit. So it really depends on the truck temperature and amount of time it has to work. What blew on the subwoofer last time?

sv3800
Posts: 3
Joined: Sun Jul 23, 2006 11:34 am
Location: Tasmania, Australia
Contact:

Postby sv3800 » Wed Sep 20, 2006 12:55 am

the voice coil went and had ben overheated
scar-non

InstallGarage
Posts: 75
Joined: Mon May 22, 2006 6:38 pm
Location: North East USA

Postby InstallGarage » Wed Sep 20, 2006 8:36 pm

What about the variables described above? Also who did the installation of your equipment?


Return to “FOUR - Difficult”

Who is online

Users browsing this forum: No registered users and 1 guest