Help me!

Miscellaneous Questions
aaronjp1990
Posts: 3
Joined: Fri Sep 01, 2006 11:48 am

Help me!

Postby aaronjp1990 » Fri Sep 01, 2006 11:52 am

Hello i have just orderd an Audiobahn: AWIS10P - 10" subwoofer. it has 3" quad-voice coils and i was wondering how i would go about wiering it up.

InstallGarage
Posts: 75
Joined: Mon May 22, 2006 6:38 pm
Location: North East USA

Postby InstallGarage » Fri Sep 01, 2006 5:57 pm

What amplifier are you hooking it up to?

A good read is http://www.discountcaraudio.net/parallelseries.html to figure out how to achieve different ohm loads.

aaronjp1990
Posts: 3
Joined: Fri Sep 01, 2006 11:48 am

Postby aaronjp1990 » Sat Sep 02, 2006 9:59 am

well i am planing on hooking it up to a Orion: 1200D - 1200W RMS Mono Amplifier or a Orion: HCCA-D5000 Mono Amplifier, it all depends on the money i have at the time lol.

InstallGarage
Posts: 75
Joined: Mon May 22, 2006 6:38 pm
Location: North East USA

Postby InstallGarage » Sat Sep 02, 2006 2:25 pm

Both those amplifiers are stable at 2 ohms. The Audiobahn website has each voice coil list at 2 ohms. To run all voice coils at the same time in a 2 ohm load, hook two sets together in a series connection. Repeat with the two other sets and then hook those sets together in a parallel connection.

Raz
Posts: 10
Joined: Sat Aug 26, 2006 6:46 pm

Postby Raz » Sat Sep 02, 2006 3:57 pm

was looking at thier website & that sub looks like it'd pound, let us know how it sounds when you get it all hooked up! :D

aaronjp1990
Posts: 3
Joined: Fri Sep 01, 2006 11:48 am

Postby aaronjp1990 » Mon Sep 04, 2006 2:59 am

alright thanks b a few weeks untill i can get amp anyway and ill let you know how it sounds.


Return to “Miscellaneous Questions”

Who is online

Users browsing this forum: No registered users and 1 guest